neocgit

a more 'modern' version of cgit
Log | Files | Refs | Submodules | README | LICENSE | git clone https://git.ne02ptzero.me/git/neocgit

commit 44ccae4227060f91c60ad45de1188e728ce8af0d
parent f759cc0f08c195940de05d5394f7b1ad4d44365e
Author: Natanael Copa <ncopa@alpinelinux.org>
Date:   Wed, 22 Jan 2014 13:15:08 +0100

makefile: use LUA_PKGCONFIG to set Lua implementation

This breaks compat with the previous LUA_IMPLEMENTATION but gives more
flexibility in that user can specify the pkg-config package name
directly.

Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>

Diffstat:
MREADME | 11++++-------
Mcgit.mk | 36++++++++++++------------------------
2 files changed, 16 insertions(+), 31 deletions(-)

diff --git a/README b/README @@ -38,14 +38,11 @@ If you'd like to compile without Lua support, you may use: And if you'd like to specify a Lua implementation, you may use: - $ make LUA_IMPLEMENTATION=JIT + $ make LUA_PKGCONFIG=lua5.1 -for using the LuaJIT project. Or: - - $ make LUA_IMPLEMENTATION=VANILLA - -for the mainline Lua project. If you specify neither implementation, it will -be auto-detected, preferring LuaJIT if both are present. +If this is not specified, the Lua implementation will be auto-detected, +preferring LuaJIT if many are present. Acceptable values are generally "lua", +"luajit", "lua5.1", and "lua5.2". Dependencies diff --git a/cgit.mk b/cgit.mk @@ -29,30 +29,18 @@ ifdef NO_LUA LUA_MESSAGE := linking without specified Lua support CGIT_CFLAGS += -DNO_LUA else -LUAJIT_CFLAGS := $(shell pkg-config --cflags luajit 2>/dev/null) -LUAJIT_LIBS := $(shell pkg-config --libs luajit 2>/dev/null) -LUA_LIBS := $(shell pkg-config --libs lua 2>/dev/null) -LUA_CFLAGS := $(shell pkg-config --cflags lua 2>/dev/null) -ifeq (JIT,$(LUA_IMPLEMENTATION)) - ifeq ($(strip $(LUAJIT_LIBS)),) - $(error LuaJIT specified via LUA_IMPLEMENTATION=JIT, but library could not be found.) - endif - LUA_MESSAGE := linking with selected LuaJIT - CGIT_LIBS += $(LUAJIT_LIBS) - CGIT_CFLAGS += $(LUAJIT_CFLAGS) -else ifeq (VANILLA,$(LUA_IMPLEMENTATION)) - ifeq ($(strip $(LUA_LIBS)),) - $(error Lua specified via LUA_IMPLEMENTATION=VANILLA, but library could not be found.) - endif - LUA_MESSAGE := linking with selected Lua - CGIT_LIBS += $(LUA_LIBS) - CGIT_LIBS += $(LUA_CFLAGS) -else ifneq ($(strip $(LUAJIT_LIBS)),) - LUA_MESSAGE := linking with autodetected LuaJIT - CGIT_LIBS += $(LUAJIT_LIBS) - CGIT_CFLAGS += $(LUAJIT_CFLAGS) -else ifneq ($(strip $(LUA_LIBS)),) - LUA_MESSAGE := linking with autodetected Lua +ifeq ($(LUA_PKGCONFIG),) + LUA_PKGCONFIG := $(shell for pc in luajit lua lua5.2 lua5.1; do \ + pkg-config --exists $$pc && echo $$pc && break; \ + done) + LUA_MODE := autodetected +else + LUA_MODE := specified +endif +ifneq ($(LUA_PKGCONFIG),) + LUA_MESSAGE := linking with $(LUA_MODE) $(LUA_PKGCONFIG) + LUA_LIBS := $(shell pkg-config --libs $(LUA_PKGCONFIG) 2>/dev/null) + LUA_CFLAGS := $(shell pkg-config --cflags $(LUA_PKGCONFIG) 2>/dev/null) CGIT_LIBS += $(LUA_LIBS) CGIT_CFLAGS += $(LUA_CFLAGS) else